Hyper-V RemoteFX doesn’t work with Shielded VMs

Cause

Recently I replaced my workstation and that was a perfect time to rebuild my home lab. After I got green lights from my employer to install the all new Windows 10 Creators Update, I also installed Hyper-V and started to build servers in my lab. I was playing around with Shielding, Virtual TPM and SecureBoot until I found out that RemoteFX didn’t work anymore. I added the RemoteFX adapter to a VM with shielding enabled, but saw in the Hyper-V Settings menu that “0 virtual machines are currently using this GPU”. I first thought about updating my drivers, but I realized that I was playing around with some new features. After disabling Shielding for this VM, RemoteFX started to work!

Solution

When RemoteFX doesn’t work, check if VM Shielding has been enabled. Disable VM Shielding and test your connection again with RDP.

0 virtual machines are currently using this GPU

2 thoughts on “Hyper-V RemoteFX doesn’t work with Shielded VMs

  1. I can’t seem to get remoteFX working under a windows 10 pro host, windows 7 enterprise guest. Did you have any luck with any similar situations?

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s