SCCM – PXE stopped working after configuring Update Server in VMM

Recently I connected System Center – Virtual Machine Manager with WSUS. The WSUS server is installed on the primary site server of my SCCM 2012 R2 SP1 CU2 installation. After I configured my SCCM WSUS server as an update server for VMM, the distribution point in the office stopped working. You will see HTTP ERROR “12030” in your logs and the PXE request on a client will fail. Browsing to the website of the SCCM Primary Site server will fail too.

I found out that the certificate of IIS on my primary site was gone. There was no certificate selected for the Default Website. After adding the certificate again and restarting IIS, PXE started to work again.

SCCM – SMSPXE.log shows Untrusted certificate

Recently I found the following error in the SMSPXE.log log file on my newly created distribution point:

CryptVerifySignature failed, 80090006 SMSPXE <REMOVED TIME> 2500 (0x09C4)
untrusted certificate: <REMOVED CERTIFICATE> SMSPXE <REMOVED TIME> 2500 (0x09C4)
Failed to get information for MP: https://SCCMPRIMARY.DOMAIN.TLD. 80090006. SMSPXE <REMOVED TIME> 2500 (0x09C4)

After recreating my certificate template for the IIS Service on the primary site server, it fixed the problem. Check the online documentation of SCCM for the details of this certificate template.

 

Remote Desktop Services – Certificate state ‘success’ but level is ‘not configured’

I had a small issue with my Remote Desktop Services Lab environment. I wanted to add a by my PKI infrastructure signed certificate to the Remote Desktop Roles. I created a certificate template like in this post. When I was importing the certificates into the wizard, the certificate looks fine because the state after selecting the certificate says “Success”.

CertificateError

Continue reading